The Hedera testnet reset has been completed and the network is available to users. Final verifications are in progress.
Posted Oct 29, 2024 - 17:03 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 29, 2024 - 17:00 UTC
Scheduled
Hedera will be upgrading the Hedera testnet to v0.55 on Tuesday, October 29 2024 at 17:00 UTC. The upgrade will take approximately 40 minutes to complete, users should expect some disruption to network services during this time.