Hedera Testnet smart contracts

Incident Report for Hedera

Resolved

The issue affecting Hedera Testnet Smart Contracts has now been resolved.

The update resolving the issue has been released to Testnet in v0.64.2.

https://status.hedera.com/incidents/fk8hvt7p3vhd

If you are experiencing any unexpected behaviour, please raise this on the Hedera Discord: https://hedera.com/discord
Posted Aug 07, 2025 - 17:13 UTC

Investigating

We’re investigating an issue on the Hedera Testnet affecting smart contracts. The behaviour was first reported starting 31 July 2025.

Deployments may succeed, but you may experience:
- Contract bytecode not appearing on Hashscan
- Read/function calls failing with a BAD_DATA error
Posted Aug 05, 2025 - 14:51 UTC
This incident affected: Hedera Testnet (v0.65.0) | Network Uptime.